3 like 0 dislike
8.4k views

Write a program that reads the number of students who passed and failed in the exams and displays the percentages. For example:

輸入及格與不及格人數
輸出及格與不及格百分數

Example input:

12 8

Example output:

Success Ratio: 60%
Fail Ratio: 40%
[Exercise] Coding (C) - asked in Chapter 4: Expressions by (12.1k points)
ID: 25730 - Available when: Unlimited - Due to: Unlimited

edited by | 8.4k views

86 Answers

0 like 0 dislike
Hidden content!
#include * ** * *

int main(){
** * * *** *** ** ** a,b;
* * * *** * ** * *** *** passed,failed;
** * * ********* * ** * total;
* * ** * ** * *** * * ** *
* * * * *** *** ** * ** ** *** * *** * * ***
* ******** * * ** ***** = a+b;
* * * * ** ** * * ** = (float)a/total*100;
* ** * ***** ** ** ** = (float)b/total*100;
*** * * *** * ****
* * * * ** *** ***** * ** * * * Ratio: %d%%\n", passed);
* * * ** ******** * ** * *** * ** Ratio: * ** ** **
* * ** * **
** **** * * * * * *** 0;
}
answered
0 0
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
#include <stdio.h>

int main(){
* * ** ******* ** * a,b;
*** *** * * **** ** * * * * passed,failed;
* * ***** * *** ***** *** total;
** * ** ** *** *** *
***** ***** * ** * ** * *** *** * * *** ** * * * *
*** *** *** * *** ** * = a+b;
*** **** * * *** * *** * = (float)a/total*100;
**** * ** * *** ******* * = (float)b/total*100;
* *** * ***** **** *** **
*** *** ** *** * ** * ***** * * passed);
* *** * ** *** * * **** ** ** **** ** * ***
* ** * * *
* ******* ** * ** ** *** * 0;
}
answered
0 0
Case 0: Wrong output
Case 1: Wrong output
0 like 0 dislike
Hidden content!
#include <stdio.h>

int main(){
* ** * ** ** ** ** a,b;
* **** ** ** * ** * ** passed,failed;
* * ** ** * total;
** * *** * * * ** * **
* ** ** ** ***** * * * * * ** ** * * * * ** ** ** **
* *** * ** = a+b;
* ** * ** ** ** * * = (float)a/total*100;
** ****** ****** **** ** ** = (float)b/total*100;
** *** ** * *
**** * ** * ** **** *** * * * * * * * * * passed);
** * * * * * ******** *** * ** *** * ** * ** **
**** **** *** **** * *** **
* * * ** ** * * * *** 0;
}
answered
0 0
prog.c: In function 'main':
prog.c:13:16: warning: unknown conversion type character 0xa in format [-Wformat=]
     printf("%d%\n", passed);
                ^
prog.c:14:16: warning: unknown conversion type character 0xa in format [-Wformat=]
     printf("%d%\n",failed);
                ^
0 like 0 dislike
Hidden content!
#include <stdio.h>

int main(){
* *** * * * * *** * ** a,b;
* * ** *** * ** * ** * * * passed,failed;
* * ** ** * * ** ** * *** total;
*** ** *** * * ******
* * *** * * *** * *** ** * * *******
***** * **** * * ***** * ** = a+b;
*** * ** *** ***** ** * = (float)a/total*100;
* ** *** ** *** **** ** ** = (float)b/total*100;
****** ** * **** *
* *** * ** * * * **** *** * * * * passed);
* * ** ** ***** ** **** ** * ***** * * ***
** * ** * ** ** **
* *** ** **** ** * * * * * 0;
}
answered
0 0
prog.c: In function 'main':
prog.c:13:16: warning: unknown conversion type character 0xa in format [-Wformat=]
     printf("%g%\n", passed);
                ^
prog.c:14:16: warning: unknown conversion type character 0xa in format [-Wformat=]
     printf("%g%\n",failed);
                ^
0 like 0 dislike
Hidden content!
#include <stdio.h>
#include ** ****

int main()
{
**** * ** * ** * *** * * * ** ** pass,fail;

* ** * * * * * ** * * ** * ** ** * *** * * *

* * ** * ** ** * * ** *** ** * * Ratio: ** * *** * *
* * ** ******** * *** * ** ***** Ratio: * ** ** **

* ****** * ** * * * ** 0;
}
answered by (-16 points)
edited by
0 0
prog.c: In function 'main':
prog.c:9:13: warning: format '%d' expects argument of type 'int *', but argument 2 has type 'float *' [-Wformat=]
     scanf("%d %d",&pass,&fail);
             ^
prog.c:9:16: warning: format '%d' expects argument of type 'int *', but argument 3 has type 'float *' [-Wformat=]
     scanf("%d %d",&pass,&fail);
                ^
0 0
Case 0: Correct output
Case 1: Correct output
0 0
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
*** ** * ** * *
int main()
{
* ** * *** ****** ****** * a,b;
** * *** ** * * * ** * * ** **** * * ** * ***** ** * *
* * ** * * * ** * * *** **** *** * * Ratio: ** *** ***** * * *
* ** * *** * * ** * ** * Ratio: %g%%",(b/(a+b))*100);
}
answered by (-214 points)
0 0
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
** ** ** * * *
int main(void)
{
** * * *** * * *** ** a, b,success, fail ;
* * ***** *** ***** * *** **** * ** ** * **
* * ** * *** * *** * * * ***
***** ** *** ** * ** * * ** * *
*** ** ** *** * * * ***** ** Ratio: %g%%\nFail Ratio: * * * *** success, fail);
* * **** * *** * * 0;
}
answered by (-304 points)
0 0
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
#include <stdio.h>

int main()

{
* ** * ** ** * * ** a,b;
*** **** **** * ***** * * *** * ** *** * ** *

* * ***** **** *** * * * ** * Ratio: ** * * * ****** *
**** * ** * *** * * ***** **** * Ratio: ** ** * ***

* * ** ** ** * ** 0;

}
answered by (-249 points)
0 0
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
** * * * * *
int main()
{
*** ** ** * ** * a,b;
* ** * ** ** * ** * * * *** ** * ** ***** * * * **
*** ** * * *** ** ** ** * Ratio: * ** *** ** **** * * **
****** ******** * *** * * * ** **** * * Ratio: %g%%",100*(b/(a+b)));
** ** *** * ** * 0;
}
answered by (-329 points)
0 0
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
*** **** * * *
int main()
  {
** **** ** * ** ** ***** ** a,b;
***** ** * ** *** * * * * ***** * *** * * *
**** ** * * * *** * * Ratio: * ** ** * * * ***
*** * * * * * * *** * * ** ** *** Ratio: * * * ** * *
* * * * ** ** *** * 0;
}
answered by (-329 points)
0 0
prog.c: In function 'main':
prog.c:5:13: warning: format '%d' expects argument of type 'int *', but argument 2 has type 'float *' [-Wformat=]
     scanf("%d%d",&a,&b);
             ^
prog.c:5:15: warning: format '%d' expects argument of type 'int *', but argument 3 has type 'float *' [-Wformat=]
     scanf("%d%d",&a,&b);
               ^
Welcome to Peer-Interaction Programming Learning System (PIPLS) LTLab, National DongHwa University
English 中文 Tiếng Việt
IP:172.70.126.14
©2016-2025

No related questions found

12,783 questions
183,442 answers
172,219 comments
4,824 users