3 like 0 dislike
8.4k views

Write a program that reads the number of students who passed and failed in the exams and displays the percentages. For example:

輸入及格與不及格人數
輸出及格與不及格百分數

Example input:

12 8

Example output:

Success Ratio: 60%
Fail Ratio: 40%
[Exercise] Coding (C) - asked in Chapter 4: Expressions by (12.1k points)
ID: 25730 - Available when: Unlimited - Due to: Unlimited

edited by | 8.4k views

86 Answers

0 like 0 dislike
Hidden content!
#include * * ** *
int main ()
{

* * * * * * * * ** * pass, fail;
* ** * *** * *** **** * * * * **
*** *** * **** ** * * * ** *** ** ** &pass, ******* *

* * ** * * **** *** **** * ** = * * **** ;
***** *** * *** **** *** = * ***
* * *** * * * **** * * * ** Ratio: ******* passratio);

* **** * ** ** ** * ** * ** ** *** Ratio: * ** ** failratio);
return 0;
}
answered by (-167 points)
0 0
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
#include * * **** ****
int main ()
{

** * ** * ** * * * * pass, fail;
** ** ** **** ** ******** * * *
** * ** ** * ********** *** * *** ** ** * * &pass, * * **

* ** ***** * ** *** * ** = ** ***** ;
* * * * **** * * * = * *** **
* * ** ** * * * *** * ** Ratio: * * ** * passratio);

** ** * * * * * ** *** **** ** Ratio: ****** * failratio);
return 0;
}
answered by (-167 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
0 like 0 dislike
Hidden content!
#include ** * * ** * **
int main ()
{

**** * ** * ** * *** * * pass, fail;
** * * * * **** * * *** ** *
*** * * ** * * *** *** ** ** * * ** * &pass, * *** * *

* **** ** *** *** * ** * = *** ** ***** ** ;
** * *** * ** **** ** * = **** * **** ***
* * * * *** * * * **** Ratio: * * ****** * passratio);

* *** **** ** **** ** * ** * * Ratio: * ** ** ** ** failratio);
* ** *** 0;
}
answered by (-167 points)
0 0
Case 0: Wrong output
Case 1: Wrong output
0 like 0 dislike
Hidden content!
#include * * *** *
int main ()
{

* * * *** * ** ** pass, fail;
* * *** ** **** ** ** ** ** *
** *** **** * ** ** ** * * ** &pass, **** *

*** * **** * *** * * * = * *** ** * ;
**** **** *** * * * * * * = ***** * *
* * * ** * *** * *** * * * * Ratio: ** *** ** * ** passratio);

****** ** ** ** ****** * Ratio: * * * **** * ** failratio);
return 0;
}
answered by (-167 points)
0 0
prog.c: In function 'main':
prog.c:11:32: warning: unknown conversion type character 0xa in format [-Wformat=]
     printf("Success Ratio:  %d%\n", passratio);
                                ^
prog.c:13:28: warning: spurious trailing '%' in format [-Wformat=]
     printf("Fail Ratio:  %d%", failratio);
                            ^
0 like 0 dislike
Hidden content!
** *** * *
int main(void)
{
* ** *** * **** a, a1,b,b1;
* * * ** ****** *** * ****** ** * * * *
** ** ** **** *********** * * *
****** **** *** *** * *
* ** * * ** ****** *** * Ratio: * ** *
******** ** ** ** ** * * * * Ratio: %g%%",b1);
*** * ** ** ** * *** 0;
}
answered by (-254 points)
0 0
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
* ** * * **
int * ***
int ** p1,p2;
** ** *** * *** *** ** *
** * * *
** *** **
** * ** **** Ratio: * * * Ratio: **** * **** *
** 0;}
answered by (-32 points)
0 0
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
**** * ** * ** ** * *
int main()
{
float a,b,c;
** * * * ** * * * * ** ** * * * * ****** * *** * * **
* * * * * * * *** * ** ** *
* * ** * * ****** ** * ** Ratio: *** ** *** **
**** ***** *** *** * * ***** ** * Ratio: %.0f%%",b/c*100);
* * * * ******* * * **** 0;
}
answered by (64 points)
0 0
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
#include <stdio.h>
int main ()
{
* ** ****** * * **** *** * a,b,c;
* ** * ** * * * ** * *** * * * ** ** ***** ** * * * *** **
* *** ** ** ** *** ****
** * *** ** * ****** * * * * * * * Ratio: ** * ** * ***
* ** * *** * ** ** ** * ** *** *** * * * * Ratio: * ** ****** *
* * * * * ***** 0;
}
answered by (54 points)
0 0
Case 0: Correct output
Case 1: Correct output
0 like 0 dislike
Hidden content!
#include <stdio.h>
int main ()
{
* * * *** ** * ****** * * a,b,c;
** * **** ** * ***** ** ** * *** *** ** ** * ***** *
** ** ** * * ** **
*** * ******* ** * *** * ********** ****** Ratio: * *******
*** * * * * ** **** * ****** * ** ** Ratio: * *** * *
* * * ** ****** * * 0;
}
answered by (54 points)
0 0
prog.c: In function 'main':
prog.c:5:13: warning: format '%d' expects argument of type 'int *', but argument 2 has type 'float *' [-Wformat=]
     scanf("%d %d",&a,&b);
             ^
prog.c:5:16: warning: format '%d' expects argument of type 'int *', but argument 3 has type 'float *' [-Wformat=]
     scanf("%d %d",&a,&b);
                ^
0 like 0 dislike
Hidden content!
* *** ** * *

int main()

{
* **** * *** * a,b,c,d;
* * * * * * * * ** * * ****** * * ***
*** * * * * *** * *** * ** ** * * ****

** ** * * ** ***** ** *** *
* ** * * *** ** ** * ** * **

* *** ***** * ** ********* ***** * *** Ratio: %.f%%\n",c);
** ** * * * * * * Ratio: %.f%%",d);
* * * **** **** ** *** * *

** * ** * * ** 0;
}
answered by (-32 points)
edited by
0 0
prog.c:3:1: warning: return type defaults to 'int' [-Wimplicit-int]
 main(void)
 ^~~~
0 0
prog.c:3:1: warning: return type defaults to 'int' [-Wimplicit-int]
 main()
 ^~~~
0 0
Case 0: Correct output
Case 1: Correct output
Welcome to Peer-Interaction Programming Learning System (PIPLS) LTLab, National DongHwa University
English 中文 Tiếng Việt
IP:172.70.127.82
©2016-2025

No related questions found

12,783 questions
183,442 answers
172,219 comments
4,824 users